11
2022
01

ip unnumbered 简介

HQY

ip  unnumbered 简介
   端口复用技术,一般用在路由器上,常用来节省IP地址。目前大部分高端路由器都支持该功能。   比如说A和D通信,A为公网主机,
D为拥有公网IP的主机,通信过程为A---B----C----D,B和C用unnumbered,也就是说B和C相当于一台路由器了(对外来说),
因为B和C的连接只是为了让A和D连接,B、C之间就没有必要3层寻址,占用两个ip地址了,所以干脆让B、C间的口借用另一边口的地址,
这样B和C就只是链路层连接了,没有必要3层做寻址了。对外好像B和C是一个设备的两个口一样。
    借用ip 地址这种功能,其最主要的目的就是节省宝贵的ip 地址资源。一个接口如果没有ip 地址就无法生成路由,也就无法转发报文。
所谓“借用ip 地址”,其实质就是:一个接口上没有配置ip 地址,但是还想使用该接口。就向其它有ip 地址的接口借一个ip 地址过来,
以使该接口能够正常使用。该功能通过ip  unnumbered 命令来实现。
   需要注意的是:
     (1)借用方不能为以太网接口。
     (2)被借用方接口的地址本身不能为借用地址。
     (3)被借用方的地址可以借给多个接口。
     (4)loopback 的地址可被其它接口借用,但本身不能借用其它接口的地址。
     (5)如果被借用接口有多个ip地址,则只能借用主ip 地址。
     (6)如果被借用接口没有ip 地址,则借用接口的ip 地址为0.0.0.0。

     1 IP unnumbered的定义:
    一个接口如果没有IP地址就无法生成路由也就无法产生IP报文转发报文所谓IP unnumbered 就是路由器一个接口上没有配置IP地址
但是还想使用该接口那么就直接利用本地 某接口网络地址作为该接口的网络地址以使该接口能够正常使用;
     2 为什么要使用IP unnumbered?
      一般来说串行链路都有独立的网络地址或子网地址但采用IP unnumbered可以帮助网络管理员 节省网络地址或子网地址空间这对于
那些不支持VLSM的路由协议诸如RIPv1和IGRP等来说 尤为有用因为作为一个网络如果它不支持VLSM 则它的WAN串行接口必须使用与
其LAN接 口完全相同的子网掩码这就意味着对于一个拥有8位255.255.255.0)子网掩码的B类地址的公司 来说即使是知道某个WAN链路上
的主机数量不会超过两台也必须为其分配一个具有253个主机 支持能力的子网而在网络上由于路由的问题本子网的其它IP地址不能再分配
这样就造成地址 的巨大浪费浪费了其余251个地址如果是支持VLSM的网络我们可以将点到点链路上的子 网划分为30bit的子网来节约地址
但对于有大量点到点链路的网络IP地址还是要分配许多如果 我们使用IP unnumbered 就可以大大节省宝贵的地址空间;
     3. ip unnumbered使用中有个最基本注意事项:
       以太口是不能配置成无编号(unnumbered)接口的,即使在串口中(同步口)中,使用也是有限制的,比如当封装成 帧中继的时候,只有点对点
的子接口才允许配置成ip unnumbered,另外X.25封装也是不允许的;



IP unnumbered 实验目的:
掌握ip unnumbered命令以及命令适用范围。
在接口上配置无编号IP地址讲义上给出了两条原则:
1. 接口必须都是串行接口,并且是被一条点到点链路连接着;
2. 在该广域网链路两端“借给”它们IP地址的局域网接口地址应属于同一个主类网络,并有相同长度的子网掩码。或者
在该广域网链路两端的局域网接口地址属于没有被划分子网的不同主类网络。

      
实验内容:
为了验证讲义中两条规则,我们将分两种情况配置IP unnumbered:

规则1:同一个主类网络的子网,并有相同长度的子网掩码:
R1(config)#interface Serial0/0
R1(config-if)#ip unnumbered FastEthernet1/0
R1(config)# interface FastEthernet1/0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)#no shut
R1(config)#router rip
R1(config)#network 172.16.0.0

R2(config)#interface Serial0/0
R2(config-if)#ip unnumbered FastEthernet1/0
R2(config)# interface FastEthernet1/0
R2(config-if)# ip address 172.16.2.1 255.255.255.0
R2(config-if)#no shut
R2(config)#router rip
R2(config)#network 172.16.0.0

规则2:没有被划分子网的不同主类网络:
R1(config)# interface FastEthernet1/0
R1(config-if)# ip address 172.16.1.1 255.255.0.0
R1(config-if)#no shut
R1(config)#router rip
R1(config)#network 172.16.0.0

R2(config)# interface FastEthernet1/0
R2(config-if)# ip address 192.168.1.1 255.255.255.0
R2(config-if)#no shut
R2(config)#router rip
R2(config)#network 192.168.1.0

使用show ip route查看路由表
debug ip rip events查看路由的更新信息
用ping命令检查网络的连通性
debug ip icmp查看数据包的转发情况

用静态路由:
R1、R2:要各写两条静态路由:
   ip route 172.16.2.0 255.255.255.0 172.16.2.1   到R2的以太网段的网段路由,下一跳为R2的串口的IP地址(就是借用的IP地址)。
   ip route 172.16.2.1 255.255.255.255 Serial0/0  到R2串口的接口路由,下一跳是R1自己的串口。

HQY
« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。